The forum for General Discussion
Post Jan 05, 2019 20:12
Hey guys,

I'm trying to get Ishar working with the WIP gamelink profile for it, and I can get the game to load in GC and it detects it and sets up a map for it, but then it won't detect my x,y coordinates or follow the avatar around. I realize the profile is a work in progress but there is youtube video of it working ( so I assume I'm doing something wrong.

Any ideas?
Site Admin
Post Jan 05, 2019 22:40
I wasn't able to get it working either, I'm planning to look into it properly once the new text tool is done.
Site Admin
Post Mar 15, 2019 09:10
I think I've fixed it (tested with the GOG release) and it'll be part of the next version (v4.3.3)
Post Apr 01, 2019 00:25
So I just gave it a try (also GOG version) and it's got the same issue as before. I load up GC, run ishar, GC detects ishar and asks to set up a properly configured map, but then there is no avatar and no position tracking at all.


Site Admin
Post Apr 01, 2019 07:20
I definitely had it working from a new game on a clean install via GOG galaxy on multiple occasions.

Not sure galaxy is relevant and iirc I loaded an end game save and that worked too.

Guess we need to play spot the difference...

First up. Is there anything different, did you press DEL on startup to change anything? Are you launching the game some other way? How clean is your install?

Is it a non English version (iirc GOG offers German versions of games sometimes)
Site Admin
Post Apr 01, 2019 07:30
Sucks that this game is being awkward. Sorry you're having problems with it.

Might be I need to pull it, but I'll need to make sure people who are perfectly happy aren't going to lose out.
Site Admin
Post Apr 01, 2019 09:03
ok I did a clean install from GOG Galaxy and it now doesn't work, but my backup copy does - so this is a breakthrough!

Site Admin
Post Apr 01, 2019 11:38
Ok the secret sauce is the Gravis Ultrasound turned off (which is what the GOG profile) stops it working and enabling it allows it to.

In the next update this won't be a problem as it'll auto-detect, but if you edit C:\Games\\Ishar\dosboxishar1.conf and change gus=false to gus=true you'll be able to play with v4.3.3

Apologies for the inconvenience
Post Apr 02, 2019 01:46
Alright I tried enabling GUS but unfortunately had no change. I'll wait for the new update before futzing with it anymore.
Site Admin
Post Apr 02, 2019 17:50
Hmmm, that is slightly concerning for me - I don't really want to release the next version with a fanfare of Ishar 1 working now! and for it not to work for you. I mean I can definitely say the GOG version didn't work and now it does - for me and 1 other person has confirmed it, but unless it works for you too that's a worry.

I wonder if I should send you an updated game link profile, or a full-on beta version ?