The forum for General Discussion
Post Sep 15, 2017 18:14

I bought this for wiz6 and some development, I tried opening up wiz 6 which i got via steam, nothing comes through as it doesn't seem to pick up the game at all, says no signal even though it says detected dosbox. Just says no video stream. help! I can't find a manual anywhere so this is fairly frustrating. :iiam:
Site Admin
Post Sep 16, 2017 16:59
( We sorted this out over e-mail :toot: )
Site Admin
Post Oct 10, 2017 10:43
Sorry, should have explained what the fix was. I believe the issue was the 'output' line wasn't set to "gamelink" so you'd get tracking (because Game Link can still access dos memory by default) but the image wasn't being piped to Grid Cartographer.

Another thing to note is the output line can get trashed by the GOG settings program - since it doesn't know about the new gamelink option - so that's another one to look out for.
Post Nov 19, 2018 01:14
I'm actually having this exact same problem again, only after trying the same fix, GC keeps asking me to update Dosbox, please help?
Site Admin
Post Nov 19, 2018 09:23
Looks like Nightdive have decided to ship Wizardry 6 with an out of date copy of DOSBox Gridc - hence the 'please update DOSBox' message you're seeing in Grid Cartographer.

I've written an instruction manual for Game Link setup on Steam, could you try following these instructions - it'd really help me out to know if they're useful or not. ... e_link.pdf
Post Nov 19, 2018 09:49
Hi David, yes I found those instructions and tried those but still had no luck.
Site Admin
Post Nov 19, 2018 13:24
Here's a copy of the instructions, I'll edit this post if we need to change anything!
For Steam releases
To setup DOSBox Gridc with games released on Steam, follow these instructions. It’s assumed
that both the game and Grid Cartographer (v4 or later) are installed and working correctly.

1. Download a copy of DOSBox Gridc from the Grid Cartographer download page:

2. Open the Steam client. Select the game in your library, right click and choose Properties.

3. On the properties dialog box, select the Local Files tab. Click the first button on the page
labelled Browse Local Files. A file explorer window should appear.

4. Find the following files: dosbox.exe, SDL.dll and SDL_net.dll. The files will either be
in the newly opened folder, or in a sub-folder. Publishers vary the locations of these files
so you may need to use the search function to assist you.

5. Extract the contents of the DOSBox Gridc .zip archive into a temporary directory.

6. Carefully copy/replace the files: dosbox.exe, SDL.dll and SDL_net.dll with the copies
from DOSBox Gridc. Make sure to copy/replace all three files.

7. Look again at the files in the ‘Local Files’ folder and locate the dosbox.conf file. Note
there may be multiple .conf files in the folder and they may be named slightly
differently, in which case choose the largest file. Open this .conf file in a text editor.

8. Search for the line that begins output=. This will be under the [sdl] section near the
top of the file. Remove the value after the equals sign and replace it so that the whole
line reads: output=gamelink. Save the changes to this file.

9. Launch the game as normal from the Steam client. A DOSBox window should open with
the logo inside which will stay. You should hear audio from the game but not see a

10. Start Grid Cartographer. The game will be visible in a viewport by selecting the [v] icon
in the top-right and choosing the LibRetro (or Game Link) option.
Note: By default, you will be informed that a game is running and given the choice to
start a new map file and also whether you’d like to switch to a split screen layout.
Site Admin
Post Nov 19, 2018 13:29
When you say it's not working, is there a particular step that didn't work? Do you see any errors in GC or in DOSBox ?

I'm thinking that steps 4-6, you might be replacing the wrong .EXE files? For me files are in:

and it's dosbox.exe, SDL.dll and SDL_net.dll that all need to be replaced.


Nightdive don't make this easy because they also distribute dosbox_gamelink.exe - which they have no reason to (although are within their rights to under the GPL). I'm going to write and ask them to remove that file specifically as it's only going to confuse people.

Additionally they ship with DOSBox Daum, another version of DOSBox which I wouldn't recommend trying to replace. Make sure you don't select that when starting the game as it'll load the wrong .EXE
Post Nov 19, 2018 13:40
Mostly it just keeps asking me to update dosbox even after I replace the exe in the file, lemme try it once more again now just replacing those specific files.
Post Nov 19, 2018 13:44
And it worked! I think what I was doing wrong was thinking I needed to replace the other gamelink exe, thank you so much for the help, cant wait to finally play wizardry again.