Thanks for reporting problems here.
POST REPLY
Post Oct 29, 2016 20:09
Just tried running GC4 for the first time since installing 16.10, but it fails to launch with an error about not being able to open libpng.12.so. It looks like Ubuntu is shipping with a newer version of libpng than it has in the past.

You can work around this by grabbing libpng12 from the repo for 16.04, but it's not exactly an ideal solution.
Site Admin
Post Oct 29, 2016 21:21
Hi Animir, thanks for taking the time to post this report.

I'm happy you were able to get Grid Cartographer 4 to work but Ubuntu is not an officially supported distro. I made sure to state 'Linux Mint 17.3 or compatible' on the buy page because of problems like this - sadly there are too many distros out there for me to support them all properly. Seems like Ubuntu is no longer compatible, at least out of the box.

For unsupported distros there will be additional libraries to install (and even then no guarantee of success) - Grid Cartographer 4 doesn't use many though: GL, GTK3 and libpng12
Last edited by David Walters on Oct 29, 2016 22:17, edited 11 times in total.
Site Admin
Post Jul 31, 2018 14:17
The next version will use libpng16 as I'm compiling with Linux Mint 19, based on Ubuntu 18.04
POST REPLY