Thanks for reporting problems here.
POST REPLY
Post Feb 22, 2019 07:24
I know that Ubuntu is not a supported OS for Grid Cartographer, but since Mint is built on top of Ubuntu I'm hoping that there may be some simple solution here. Version 4.3.0, build 4301 runs well overall, but for whatever reason the ctrl key doesn't seem to register- "ctrl+s" for example triggers the "switch" tool, as though I had just typed "s". Any likely strategies I can use to work around this locally? Or is it time for me to dust off my Windows partition?

Thanks for building & maintaining this tool, it's been very helpful for some of my D&D prep!
Site Admin
Post Feb 22, 2019 07:37
Sorry to hear this.

One thing to try is could you redefine one of the keys from Options > Input and assign it a ctrl+ letter yourself and see if that works for you? If your O/S is generating something different, hopefully this dialog will capture it and I can look into why that might be / develop a fix.

Due to historical teletype reasons I think, ctrl plus letter keys act in weird ways on Windows and Linux. I thought I had it working but it might generate something different on your system. Apologies for the inconvenience and thanks for reporting it.
Post Feb 23, 2019 22:03
I did give that a try, but regrettably the key mapping dialog doesn't seem to register ctrl either. alt and shift work fine, curiously. Not the end of the world since I have some alternative options, fortunately. Thanks for the quick reply!
Site Admin
Post Feb 28, 2019 09:50
Hmmm :iiam: That's a unique bug afaict and pretty strange! Are you running Linux natively or through a VM or remote desktop type setup?

Also, I could possibly try to reproduce this from a clean install. Which specific Ubuntu distro do I need, and if it's tweaked in some way can you also provide details there too? (I don't know Ubuntu that well and don't keep up with e.g. window manager changes, KDE, gnome etc.)

Edit: Does either CTRL key register during editing? If you hold ctrl it's supposed to switch to door drawing mode while you hold it.
Site Admin
Post Mar 04, 2019 10:09
FWIW I'm in an up-to-date Linux Mint 19 Cinnamon right now and both my CTRL keys work. Was hoping they'd have stopped working so I could work on it more easily...
POST REPLY