Thanks for reporting problems here.
POST REPLY
Post Apr 27, 2015 10:22
Hi,

It seems that terrain symbols (or textures) act little bit wonky on hex maps.

If I have empty hexmap, and I add some forest-looking texture to some hexes, they appears as solid green. Then I proceed to add other map symbols, and suddenly terrain textures will appear.

Hexmap seems suitable for outdoor maps, does anyone have hints for good outdoor symbols (Village, City, Temple etc)
Site Admin
Post Apr 27, 2015 11:24
Thanks for the report, I've not seen that before but I think I can probably fix it.

Would you be alright to post a picture, or a link to an example GCT file, or e-mail it to me here: support at david walters development dot com. I've got an idea but it'll be good to double check and have an example to test it with, thanks.
Site Admin
Post Apr 27, 2015 15:26
Okay, so I'm not sure this will fix it but one problem I've identified with hex terrain rendering is that the texture co-ordinate values could get rather large. This could cause problems with some graphics cards I think, so I've made a new beta version which addresses that issue.

v3.0.3 Beta 2.1 (Windows)

Visually this should be identical to previous versions but internally the texture co-ordinates are offset back into much smaller values which should be more broadly compatible.

If you could give this a try hopefully that solves it!

If not - the other thing which might be causing the problem, based on your description, is that the texturing in my engine is somehow going wrong and the texturing isn't wrapping correctly. Not sure why that would be happening but it seems the most likely cause if the fix above doesn't work.

So I'll wait to hear back from you regarding beta 2.1 and we'll take it from there.

Apologies for the inconvenience.
Post May 02, 2015 19:02
Sorry, I have been absent for a while. I tested it with version 3.0.3 and it seems to work. Thank you
POST REPLY