Thanks for reporting problems here.
Site Admin
Post Sep 29, 2016 21:12
MikeSol wrote:The instructions for version 3 are very different from what you posted here. Where are the instructions for version 4 besides what you posted here? I just need general instructions to see if I can get gamelink working. I am interested in this feature and I would like to try it out.
I have yet to release a manual for version 4 so the instructions aren't in one place. Since you no longer need to do much config and it 'just works' automatically now, my hope was that instructions weren't necessary. Once I've dealt with the immediate bugs I've got outstanding - I will be working on dusting off the manual I have in progress and I thought perhaps posting a link here on the forums so you can look at it and feedback as I complete it.
Last edited by David Walters on Sep 29, 2016 21:12, edited 1 time in total.
Post Sep 30, 2016 00:18
OK, I used the instructions located here to get as far as I did. -->

http://www.davidwaltersdevelopment.com/ ... =20&t=1436

Those instructions are very different from what you posted here. I will try that debug\screenshot thing now....
Post Sep 30, 2016 00:28
OK I have four screenshots, about 130KB each. I have no idea how to upload or post them though. Tell me how and you can have them. However, I can tell you that those two numbers you are talking about are NOT moving as I move around the gameworld. They remain at 00.
Post Sep 30, 2016 03:05
I'm seeing the same thing that Mike is. I'm also noticing the debug info doesn't list a region or floor; it stops at RAM-POS.

http://imgur.com/yH9lmtF
Site Admin
Post Sep 30, 2016 11:38
MikeSol wrote:OK, I used the instructions located here to get as far as I did. -->
http://www.davidwaltersdevelopment.com/ ... =20&t=1436
Those instructions are very different from what you posted here. I will try that debug\screenshot thing now....
Sorry, those instructions were meant for v3 really - you shouldn't need them now. To avoid confusion I've turned that thread into a PDF and it's now linked from the downloads page. I would undo any changes you've made based on following those old instructions and stick to the new ones I posted in the thread for MrPopo -- they will form the basis for the new manual.

Sorry for the confusion both of you, I should have done more to make this all a lot clearer prior to launch. On the plus side I'm gathering lots of useful information as gotchas so your struggle will not be in vain ;)
MikeSol wrote:OK I have four screenshots, about 130KB each. I have no idea how to upload or post them though. Tell me how and you can have them. However, I can tell you that those two numbers you are talking about are NOT moving as I move around the gameworld. They remain at 00.
Happy for you to e-mail me them to me: support at david walters development dot com (sorry, lots of bots cruise this forum)

From what MrPopo has posted it seems like there's something wrong with the acquisition of data from the game -- but it's a strange one if the video, input and detection of the game are all working. I will look into this, and hopefully be able to replicate the problem on my end and find a fix.

I have had it confirmed from someone on Linux that they were able to get Wizardry 6 to work, so it's not totally broken for everyone. I take that as a good sign that we can resolve this for you two as well.
Post Sep 30, 2016 15:04
I'd be happy to install any debug builds that might increase the log level of either application and send you said log files.
Site Admin
Post Sep 30, 2016 15:17
MrPopo wrote:I'd be happy to install any debug builds that might increase the log level of either application and send you said log files.
That might be a good idea, thanks very much for offering - I'm working on this problem right now.. will post back if I need extra data, cheers.
Post Sep 30, 2016 16:19
I emailed you the four pics with the subject header 'Screenshots from GameLink' - I sent four attachments in one email, hopefully you receive them ok. Check the gamelink icon in the lower right hand corner in each screenshot to see exactly what I see.
Site Admin
Post Sep 30, 2016 16:23
MikeSol wrote:I emailed you the four pics with the subject header 'Screenshots from GameLink' - I sent four attachments in one email, hopefully you receive them ok. Check the gamelink icon in the lower right hand corner in each screenshot to see exactly what I see.
Just got these, thanks!

I'm scratching my head a lot and trying to think what kind of extra debug info I'll need to get a good game of spot-the-difference going :)
Post Sep 30, 2016 16:33
I am trying to see if I can get MM 2 working with the instructions you have in this thread. I have the GOG version so I am following the instructions exactly as you posted them. Step 6 says 'downloaded custom dosbox from here' -- Is that the one I already downloaded in the GC 3 instructions or is it something else? If it is the same one, I have it already, but if it is different, I need a link to download it. Please confirm.
Last edited by MikeSol on Sep 30, 2016 16:34, edited 1 time in total.
POST REPLY