Thanks for reporting problems here.
Site Admin
Post Sep 30, 2016 16:40
Should be the same - it's R12 which I can see from your screenshots that you're running. None of the past versions are capable of streaming video.

btw. - I take it moving around in split-screen mode works just fine - it's literally just this tracking data that's not working?
Post Sep 30, 2016 16:44
David Walters wrote:Should be the same - it's R12 which I can see from your screenshots that you're running. None of the past versions are capable of streaming video.

btw. - I take it moving around in split-screen mode works just fine - it's literally just this tracking data that's not working?
Moving around is working just fine. Even without the working avatar, this is better then alt-tabbing like I did with GC 3.
Post Sep 30, 2016 16:54
IT WORKS!!! I see the avatar moving around as I move around.

I had to make a change to your instructions though. I saw 'no stream detected'. I had to change the GOG icon on my desktop to point to dosbox_gamelink.exe not dosbox.exe
Site Admin
Post Sep 30, 2016 17:02
Great!

Don't suppose you can tell what you did differently to make it work vs. before when it didn't?

Did you re-download Might and Magic 2 ? In ton-foil-hat mode it could be something like there's two very similar versions of MM2 in play here?

(Don't worry MrPopo I'm still working on this !)
Last edited by David Walters on Sep 30, 2016 17:03, edited 1 time in total.
Post Sep 30, 2016 17:12
David Walters wrote:
MikeSol wrote:I emailed you the four pics with the subject header 'Screenshots from GameLink' - I sent four attachments in one email, hopefully you receive them ok. Check the gamelink icon in the lower right hand corner in each screenshot to see exactly what I see.
Just got these, thanks!

I'm scratching my head a lot and trying to think what kind of extra debug info I'll need to get a good game of spot-the-difference going :)
When I get stuck on something like this I usually just go with the "log after every line with salient variables" approach. Usually ends up being that some conditional I was positive should be evaluating one way was actually evaluating another.
Site Admin
Post Sep 30, 2016 17:39
Right! here's a first stab at debug. Please download this kit i've made for you :-)

http://www.davidwaltersdevelopment.com/ ... mrpopo.zip

In it you should find - new dosbox exes that print to the console

Also a new GC4 pro with extra debug stuff in both the game link debug HUD and in the log file.

you can find the log file here:
C:\Users\%username%\AppData\Roaming\David Walters Development\Grid Cartographer 4 Pro Edition\log.txt

I've also put in a copy of my dosbox conf files - in case there's some emulation settings that cause this to fail.

There's also some screen captures of the process which show what numbers you *should* be getting

Right now I've got a funny feeling that Game Link is working just fine but it's looking for the position data in the wrong place in your particular copy of M&M2 ...


I look forward to hearing from you !! good luck :)
Last edited by David Walters on Sep 30, 2016 17:40, edited 1 time in total.
Post Sep 30, 2016 18:07
Ok. I have some info for you.

The GOG version of MM2 works fine. As does my non-GOG version of Wizardry 6. But my non-GOG version of MM 2 does NOT work. And I know why. Its the LOADFIX command. This command is necessary to get the non-GOG version of MM 2. working. But guess what? It interferes with the Avatar display in gamelink. With the LOADFIX command active, the avatar will no longer work in Wiz 6. But once I remove LOADFIX, wiz 6 avatar works again. I tested this multiple times so I am sure my info is accurate. Perhaps the GOG version of MM2 does not need the LOADFIX command to work. But the non-GOG version does.

To answer your question about what I did differently this time around, there are two things I did differently.

1. I followed your GC 4 instructions rather then your GC 3 instructions. I changed output to gamelink which I did NOT do the first time around. And this time I did not copy\paste netpeek info for individual games which I did do the first time around.

2. I used my non-gog MM2 only the first time around. Which means I needed the LOADFIX command. But as I said, this command seems to interfere with your avatar display. At least it does in Wizardry 6.

Now that is MM 2 and Wiz 6. Now onto two other games I tried.

Might & Magic 1 - My non-gog version does not work with gamelink at all. The icon in gamelink shows a red question mark. It never changes to an exclamation point. If I hover my cursor over it, it says 'unknown game' But the GOG version of the same game works just fine. Avatar and all.

Wizardry 1 - Same as above but I don't have the gog version of this one to try.

Ok that is it for now. I will help out in any way that I can, but it has to be later or even tomorrow. I have to get some work done now. I really like gamelink when it is working fully with the moving avatar. Very nice.
Site Admin
Post Sep 30, 2016 18:59
Okay, brilliant thanks for your help!

So really this is not a bug specific to v4 but rather an issue with the data Game Link was asking for (that would have affected v3 also.)

Right now I only have the GOG.com versions of most of these games so I'll have to track down alternates and make some changes to my code to handle this LoadFix thing - presumably adapting the addresses I ask for to compensate for whatever it's doing to the game.

Thanks again, that's been immensely helpful.
Last edited by David Walters on Sep 30, 2016 18:59, edited 1 time in total.
Post Sep 30, 2016 21:30
Sounds like loadfix might be the solution, but I'll still first start by running the new exes you gave me with loadfix; it might give you some insights into what's going on.
Post Sep 30, 2016 23:27
David, I think you are already aware of this but just to make sure, you have two seperate problems to deal with here.

1. LOADFIX. The only game I need this for is MM 2 but since it does not interfere with other games, I always left it on. Without this command the game won't load. With it on, the avatar in MM 2 and Wizardry VI won't work. So as of right now, as far as I can tell, non-GOG MM 2 will never fully work in Gamelink.

2. Non-gog versions of MM 1 and Wizardry 1 are not working at all. Forget about the avatar, gamelink won't even recognize these as games they support. So it looks like non-gog versions of at least some games are different from their GOG counterparts in a way that is completely screwing with gamelink. LOADFIX has nothing to do with this second problem.

With your permission, I would like to send you my non-gog versions of MM 1 and MM 2. Maybe with them, you can figure out what is going on. I can just email them to the same address you gave me before. Please let me know if you are ok with this or not. I have Winrar on my end. I believe winzip can handle that.
Last edited by MikeSol on Sep 30, 2016 23:28, edited 2 times in total.
POST REPLY