Thanks for reporting problems here.
Post Sep 28, 2016 16:06
Ok, I just upgraded to version 4. At first everything was fine. I remapped a bunch of keys and played around with it a bit but now it is crashing almost immediately after opening it. Version 3 is still working fine. I am using Windows 7 Ultimate 64-bit. The error is ' Gridc64pro.exe has stopped working'. Underneath that, I am seeing this which I am copy\pasting here. --->

Problem signature:
Problem Event Name: BEX64
Application Name: gridc64pro.exe
Application Version:
Application Timestamp: 57e954d2
Fault Module Name: StackHash_0ff9
Fault Module Version:
Fault Module Timestamp: 00000000
Exception Offset: 000000000012fcf9
Exception Code: c000001d
Exception Data: 00000000badc0de1
OS Version: 6.1.7601.
Locale ID: 1033
Additional Information 1: 0ff9
Additional Information 2: 0ff91a5d6dd988e4bb0dafc29c33e6c5
Additional Information 3: 7846
Additional Information 4: 7846b88b14ea19579ca84c567a682b29
Site Admin
Post Sep 28, 2016 16:30
Hi, I'm sorry you're getting a crash.

The problem seems to be possibly coming from a 3rd party problem. Googling BEX64 and stackhash (which are new to me) it seems that, for example here: ... ash_error/ That the crash can be caused by anti-virus program or advanced features of graphics card drivers.

Can you confirm if you're running any anti-viral software? Also are you running any graphics card enhancement software like Radeon or NVidia 'overlays' or recording software - Grid Cartographer uses DirectX9 and to a graphics driver might probably look like it's a game. Also since it's new it might be flagged by an AV program and be messed with on some low level?


I'm also open to it being a software bug but if it's crashing when idling after an uncertain amount of time (?) that seems like an external influence to me.

If you'd like to mail me the contents of your user data folder:
C:\Users\%username%\AppData\Roaming\David Walters Development\Grid Cartographer 4 Pro Edition
I can drop that in and I can check to see if the config is corrupted somehow.

You can also try making a backup of that and uninstall/ re-installing to see if the problem persists with a fresh install (the config files should all be deleted during the uninstall process)

.. Hope we can get to the bottom of this!
Post Sep 28, 2016 19:36
Ok. I did three things.

1. I reinstalled Grid 4. The only file I copied over was the keymap one.
2. I told my antivirus to stop real time scanning the two directories your software is installed to.
3. I turned off several programs in startup (msconfig) that I was not using including a few nvidia ones.

It always crashed within 5 seconds (maybe 10 seconds) upon launching it. This is still happening unfortunately. When I installed it the second time, everything seemed fine at first. But after a few restarts of it, it began crashing again. Exactly like the first time. It does not matter if it just sits there or if I am actively using it. It will just crash. If it does not crash within that 5-10 seconds it seems to be ok.

I don't know what nvidia overlays are so I dont think I am using anything like that. If you would still like the contents of the folder, please give me your email address or tell me how to upload them here.

I very much want GC to work, so whatever ideas you have, I will try.
Site Admin
Post Sep 28, 2016 20:28
Hmm, this is a tricky one! If reinstalling it didn't fix it then there doesn't sound like there's a problem with the config.

One thing that I guess might happen 5 - 10 seconds after startup is the update checking. If you open up your config file "editor-settings.ini" and find the line "update.enabled" and change it to "false" (without the quotes). Can you try that?

Beyond that it's probably either a graphics card / driver issue, or something relating to the Game Link 2.0 feature. I'll have to make a special build for this but I can completely remove game-link - that will help eliminate that as a cause. I'll post back when that's ready.

Again, the google results for this crash give a huge list people with problems on different products and it all sounds like a driver issue or some kind of system instability every time I look into them. I hope this is something I can fix. So far no other reports have come in like this.
Last edited by David Walters on Sep 28, 2016 20:28, edited 1 time in total.
Site Admin
Post Sep 28, 2016 20:55
Okay, here's a version of GC4 Pro with game-link 2.0 video sharing part compiled out. Combined with turning off the updates this should be a pretty inert version. Unzip this EXE and copy into your GC4 pro install folder. ...

So, methodically, we should have 4 results:

1. standard GC4 Pro. + Updates turned ON. Result = Crash after 5-10 seconds, regardless of user input.
2. standard GC4 Pro. + Updates turned OFF. Result = ?
3. nogamelink .exe + Updates turned ON. Result = ?
4. nogamelink .exe + Updates turned OFF. Result = ?

I'll have my fingers crossed !
Last edited by David Walters on Sep 28, 2016 20:56, edited 1 time in total.
Post Sep 29, 2016 01:54
Ok methodically then...

1. The crash happens maybe half the time I launch it. It happens exactly 6-8 seconds after starting GC. Yes, I timed it. If the crash does not happen in that 6-8 seconds, it never happens. So right now, launching GC is a crapshoot for me. ;)

2. See above. Same result. I don't think udpates is causing the issue since the crashes still happen.

3. Did not test this. Will test tomorrow. But I am guessing this will stop the crashes because.....

4. No more crashes... so far. I am going to test this and #3 further and get back to you. I will post again tomorrow. For now, I recommend keeping your fingers crossed. I will be.

But seriously, thank you. I know this is only happening to me.
Site Admin
Post Sep 29, 2016 07:54
Okay then. It's sounding promising. I'm not sure why it's incompatible with your system but it's something to go on. I would suggest you turn updates back on and make sure it's not crashing, I can then look at more fine grained debugging.

Apologies for this inconvenience, your patience and understanding is greatly appreciated!
Post Sep 29, 2016 18:02
Ok, did some more testing.

The new executable you gave me crashed exactly ONE time. I restarted GC many many times. When I went back to the original executable, the crashes became far more frequent. Updates set to TRUE or FALSE does not seem to make any difference with either EXE. I did copy the error just in case it is different (though I do not think it is) so I am going to post that here now. Again though, I only saw this one time after many restarts. --->

Problem Event Name: BEX64
Application Name: gridc64pro_nogamelink.exe
Application Version:
Application Timestamp: 57ec2bdd
Fault Module Name: StackHash_fd46
Fault Module Version:
Fault Module Timestamp: 00000000
Exception Offset: 000000000012fcf9
Exception Code: c000001d
Exception Data: 00000000badc0de1
OS Version: 6.1.7601.
Locale ID: 1033
Additional Information 1: fd46
Additional Information 2: fd46daf28d746632341810df0a557a96
Additional Information 3: 5158
Additional Information 4: 51585d86544c1417e38987f6edd7d4a5
Site Admin
Post Sep 29, 2016 20:39
Okay, well I was all set to create a debug version that logged Game Link in great detail and tried to drill down into the problem but if it's got this StackHash crash again without it even having the code in the EXE then it can't be that. I would ditch that special version I made for you as it feels like a dead-end.

I think at this point I'm mostly all out of ideas. It obviously doesn't like your PC for some reason.

Have you tried running stock GC4 in Windows safe mode ?

Have you run a RAM test - to check for hardware faults ? ... -problems/

Have you tried stock GC4 after completely disabling your anti-virus (not just excluding the folders, which you've tried) ?

If you Google Stackhash and BEX crash you get a lot of results for all sorts of programs - seems every one has them and no-one knows why.

I really don't know what else to say. :iiam:
Post Sep 30, 2016 00:02
Ok. I checked my memory from that link you gave me. No issues there.

I was going to disable my antivirus software but I can't figure out how to. When I uncheck it in msconfig, it just rechecks itself when I hit apply! So instead, I just disabled everything else. Under the services tab I disabled all non-Microsoft services. In startup I turned off everything. So the only thing left running was my antivirus software.

I rebooted, and the stock exe gc4 stopped crashing. I booted it over 50 times. Yes, I actually counted. No crashes. Well good. So it is one of my programs. No problem. Let me figure out which one it is....

First I decided to just turn everything back on, and rebooted. I expected it to start crashing again, but after many many restarts (I was not counting this time) I could not get it to crash. I am trying right now to get it to crash as I type this, but I can't get GC to crash. I turned on the exact same things I had before so I no longer have any idea what is going on.

So either turning off everything and then turning it all back on again fixes bex64 errors or this is the most random crash I have ever encountered. Like you said ---> :iiam:

I say we both just move on... the crashes were at their worst yesterday, but even then, GC was perfectly usable.

Just one question, what does that other EXE you gave me to try actually take away? What is non-functioning in that version? Game link?