Thanks for reporting problems here.
POST REPLY
Post Nov 19, 2017 13:05
I just started using Grid Cartographer, and I'm quite happy with it so far, but I have found a bug. I'm using Linux (X11 on Debian testing), and instead of the us QWERTY keymap, I use the dvorak keymap with the ctrl:nocaps option. Under this configuration, Grid Cartographer appears to inconsistently use X-mapped input for some keys and the raw keycodes (I'm guessing) for others. In particular:
  • My physical "CapsLock" key is mapped to CTRL by the ctrl:nocaps option, but seems to have no effect in GC.
  • Keys which produce symbols under QWERTY but letters under Dvorak are given their QWERTY meaning in some contexts. I've noticed at least:
    • When pressed with CTRL in the main editing UI. E.g., pressing Dvorak S is handled as S, but pressing Dvorak CTRL-S is handled as CTRL-;
    • In the Options > Input > Key mapping screen when setting a hotkey. E.g., pressing Dvorak S is handled as ;
Thanks!

[Edited to remove <code> blocks -- I should have previewed first to see how they rendered!]
Post Feb 11, 2018 01:01
Bump. Is this in the queue for a fix in a later release?
Site Admin
Post Feb 11, 2018 11:23
Hi llasram, firstly apologies for not replying to this report until now.

Ideally I'd have a DVORAK keyboard to fix/test this but they seem to be hard to find here in the UK and probably not cheap. However perhaps there's some kind of cheat-sheet I could make - if you can send me a link to a picture of your keyboard (or tell me the precise model number so I can look for it) I could devise one - then set mine up with that nocaps profile you're using (assuming Linux Mint supports it) and potentially test any fixes that way.
Post Mar 10, 2018 01:46
And now my turn to apologize for the delay in response!

In any case, I believe this issue is disjoint from using a hardware Dvorak keyboard, and that it in fact depends on *not* using one. A hardware keyboard with a non-standard layout should change the mapping of physical keys to keycodes, and the problem here seems to be a disconnect in the mapping of keycodes to key symbols.

On any Linux distribution using X (including e.g. Mint) you should be able to use a virtual terminal to run the command:

Code: Select all

setxkbmap -option ctrl:nocaps dvorak
This should switch to the Dvorak keyboard layout with CAPSLOCK mapped to be another CTRL key, as per my configuration. The resulting layout should match what you can find at e.g. https://en.wikipedia.org/wiki/Dvorak_Si ... d_Keyboard.

You can switch back with

Code: Select all

setxkbmap gb
(Assuming from your last comment that you are using a standard UK keyboard layout.) You may find it useful to run this command first so you can restore your normal layout just by going back through your shell history with the up-arrow key enough times.

Please let me know if I can be of any more help in diagnosing this issue from your end, and I will attempt to check back in here more than once a month!
POST REPLY