Thanks for reporting problems here.
Post Oct 31, 2018 18:37
Here's a fun one that's baffled me for the last day.

I'm playing through Might & Magic 3, as purchased from GOG (runs on DOSBox). It was working as intended on the version of GC before 4.3... I think 4.2.1? No problems. I've been running windowed DOSBox and GC side by side, without doing the embedded GameLink view inside of GC itself.

Last night I upgraded to 4.3 and changed nothing else. Everything works on launch, but now if I focus Grid Cartographer, the audio from DOSBox cuts out. Focusing any other app doesn't exhibit the issue, only GC. Focusing anything other program but GC restores the game's audio. I suspect GC is somehow stomping on the audio pipeline, starting in 4.3.

Furthermore it seems it only stomps on DOSBox. Other audio-producing apps like Foobar2000 can still output audio while GC is focused.

Things I've tried to fix this:
  1. Muting GC, or setting its volume to 0% in the program
  2. Muting GC in Windows volume mixer
  3. Using vanilla DOSBox or the GameLink hacked DOSBox; both exhibit the issue
  4. Running DOSBox in admin mode to see if it could stomp back on GC stomping on its audio
  5. Running a different DOS game (Mystic Towers, Titus the Fox, etc). All of them lose audio when GC is focused
Maybe GC is eating DOSBox's audio because it expects to be handling the DOSBox display all the time now? Thoughts? Can anyone even replicate this?

This is a Win10 box, embedded Intel audio, standard line out to 2.0 speakers. Nothing special.
Site Admin
Post Nov 01, 2018 14:16
Hi Trysdyn, thanks for the bug report.

I've tried to reproduce this problem with a fresh install of MM3 (simply set the .conf to fullscreen=false mode), Custom DOSBox r17 and GC Gamer v4.3.0 but... it works just fine. I'm not sure why it wouldn't - unless there's a problem with OpenAL on your system, Windows should all mix everything together without issue...

You mention this problem has happened in v4.30. How about the last v4.1.2 beta? I've not changed too much to do with this older Game Link as my focus has been on LibRetro work - I'm not ruling it out, but it seems strange. v4.1.1 makes more sense as it has no audio in it. If you could try those that might help.

One thing I've been doing today anyway is moving my dosbox port over to github:

I've not encountered the problem with this build either (it's largely the same code, so that's expected). Here's an .exe for you to try though just in case: ...

I've checked and the setting of the GC volume slider is *not* being picked up by dosbox in this 'no video stream' configuration (it uses 100% in this mode), only in the picture-in-picture mode. So there shouldn't be any problem there.

btw. I take it the audio is working fine in picture-in-picture mode? This 'tracking only' mode is still supported but it would be useful to know - in PiP mode, DOSBox.exe is still responsible for making the sounds.
Site Admin
Post Nov 01, 2018 14:34
One thing I would point out is that I had to modify SDL in my custom dosbox to give the audio global focus as otherwise they will go quiet when the window focus is lost. Are you using my custom dosbox.exe *and* the SDL dlls that come with it?
Post Nov 08, 2018 19:45
Hey David, sorry I haven't had time to stream lately so I haven't had a chance to test this; I just fired it up to check things out.
David Walters wrote:
Nov 01, 2018 14:34
One thing I would point out is that I had to modify SDL in my custom dosbox to give the audio global focus as otherwise they will go quiet when the window focus is lost.
Thiiiiis turned out to be the problem. I dunno why audio was lost *only* when GC was focused and why this seemed to break between versions, but when I moved from streaming MM2 to MM3 I only copied over dosbox.exe, not the libs, and the timing of such made me just assume it was the version bump. I may be a moron :)

Thanks for the info.
Site Admin
Post Nov 08, 2018 22:05
Glad you got it sorted out! tbh I don't think modifying SDL was fair of me ;) I'll look into a way to use it properly and get the same result. I agree it's weird that the two programs interacted like that, but I'm glad it's working for you now.
Site Admin
Post Nov 09, 2018 14:55
Just a quick follow up to say that I looked into the SDL source code to see if I could ask it to use global sound focus via it's API, but unfortunately this doesn't seem to be an option. So a custom SDL.DLL is definitely required.

Seems like the best I can do without replacing SDL is document this problem in the troubleshooting page of the Game Link manual.