Thanks for reporting problems here.
Post Sep 28, 2016 04:25
I'm trying to get Might & Magic 2 working with game link. I've configured my dosbox conf to have an output of gamelink. I've got Grid Cartographer 4 opened (Pro, if it matters) and the icon in the lower right corner indicates Game Link is detecting something. I click it and it says "Unknown game". I am using the DOSBox R12 from the link on your main page. Here's the run section of my dosbox conf:

# Lines in this section will be run at startup.

mount C "..\Might and Magic 2"
#loadfix -4 mm2.exe
loadfix -4
Last edited by MrPopo on Sep 28, 2016 04:26, edited 1 time in total.
Site Admin
Post Sep 28, 2016 08:02
Hi there, sorry you're having difficulties.

If you go to the view tab in Grid Cartographer and chose one of the the split screen views, do you see the game or any signs of life from dosbox? Alternatively you might see a static 'no signal' display or some other weird behaviour ?

What operating system are you running Grid Cartographer and dosbox on ?

Are you using the version of Might and Magic 2, or some other version ?

Here's what I'm getting on windows 10 x64 using the MM2: ... mrpopo.png

note: It's normal for the dosbox logo to stay on like that.
Last edited by David Walters on Sep 28, 2016 08:03, edited 1 time in total.
Post Sep 28, 2016 14:54
I didn't try playing around in the view tab; I'll give that a shot when I get home tonight. I'm on Win 10 x64 with the GOG version.
Site Admin
Post Sep 28, 2016 15:23
MrPopo wrote:I didn't try playing around in the view tab; I'll give that a shot when I get home tonight. I'm on Win 10 x64 with the GOG version.
Okay, great - that should work. Let me know if it doesn't.

I'll work on a way of making the game link stuff announce itself a bit better since I've have a couple of people think it's not working due to the way it's currently presenting itself.
Post Sep 29, 2016 02:36
Switching to the split views did it; now I can navigate with the embedded window in GC and the icon in the lower right recognizes I'm playing Might & Magic 2. There was actually a separate problem; my dosbox conf was mounting the C drive incorrectly (which I was able to see through the console menu shown in the GC game link).

Now the only problem I'm having is I can't seem to get the auto tracking to work the way I'd expect. I have it turned on in the options but when I spin up MM2 the avatar tool disappears. I've tried casting Location to see if that's what's needed to kickstart the process but to no avail. My understanding was that it should be passing in the position information as I move (or at least I'd expect it to pick up me moving NSEW). When I mouse over the game link icon in the lower right it has the tooltip Player Location Not Available. GC did prompt me to load a map that was compatible with the game, and I'm currently on a map named Middlegate.
Site Admin
Post Sep 29, 2016 09:32
That's odd. Here's a complete set of instructions for how I got to this point: ... 2-popo.png

0. Clean reboot, nothing running.
1. Download and run the Might and Magic II installer from ( setup_mm2_2.1.0.42 )
2. Installed to C:\Games\Might and Magic II
3. After install, didn't use the 'launch now' option
4. Opened up C:\Games\Might and Magic II in File Explorer
5. Deleted the dosbox folder
6. Downloaded custom dosbox from here
7. Extracted the dosbox folder into C:\Games\Might and Magic II, to replace what was there.
8. Opened "C:\Games\Might and Magic II\dosboxMM2.conf" in a text editor
9. Changed the output line to read output=gamelink
10. Ran the game from the desktop shortcut the installer created.
11. Started Grid Cartographer 4
12. Went to View > Horizontal Split -> saw the Might and Magic II title screen.
13. Clicked the red exclamation! mark and said OK to create a new map
14. Middlegate region appears and the icon turned to a green ?
15. Clicked on the game link view - got a yellow outline showing that the input is locked
16. Pressed S, G and then CTRL A through F to start a new game with the default party.
17. Then pressed Z
18. The Avatar marker should now appear on the map view at co-ordinate (7,3)
19. You can now walk and turn around and the marker will track you.

I also remembered what you said and went to Options > Game Link and clicked 'Activate' to see if that was interfering or causing a bug, but the tracking kept on working.

If you can follow those steps, or look through them and see whether I've done something you didn't expect or realise that would be great. This is a complex feature and I'm sure there's some confusion to clear-up. I'm making a note of these sorts of things for future updates - to try and make v4 the most friendly version yet.
Post Sep 29, 2016 15:58
Those are effectively the same steps I did. The main thing that sticks out as different is that I didn't nuke the DOSBOX folder; I just dropped the files from your installation on top and replaced everything. So I'll definitely give nuking out the folder a try just in case. But otherwise I followed those same directions.

Now that I think about it, there is one major difference that may or may not matter. I had already exited town with Z before I clicked the red icon to load up the Middleton map. So maybe that desynced things? The end result I saw was there was no Avatar marker on the map and the Move avatar marker button was greyed out (the latter is what I'd expect in game link, to keep users from messing something up).
Site Admin
Post Sep 29, 2016 16:01
Okay, let me know how it goes and i'll try and support you in getting to the bottom of things :) -- I'm pretty confident it's just something being a bit confusing rather than a bug, but we'll see !
Last edited by David Walters on Sep 29, 2016 16:01, edited 1 time in total.
Post Sep 29, 2016 18:51
I got exactly as far as MrPopo did by following the instructions for version 3. I have MM2 on the left and GC on the right in view. But I see a green question mark in the lower right corner. If I hover my cursor over it, it says 'player location not available'. I see no avatar on the map. Auto tracking is enabled. I tried with Wizardry 6 and I get the exact same result.

The instructions for version 3 are very different from what you posted here. Where are the instructions for version 4 besides what you posted here? I just need general instructions to see if I can get gamelink working. I am interested in this feature and I would like to try it out.

And yes, I used the original exe to test out gamelink, not the stripped down version you provided me with to try and solve the crash problem in the other thread. ;)

And no MrPopo, it does not matter if you click the icon to make the map before or after you enter Middlegate. I already tried.
Last edited by MikeSol on Sep 29, 2016 18:53, edited 1 time in total.
Site Admin
Post Sep 29, 2016 20:54
I'd be very interested in what either of you see when you enable the debug hud for game link. That can be done by going to Options > Game Link > "Show Debug HUD (Advanced)"

You should see something like this (I've cropped the top-left of the display, to show that MM2 is running but to keep the text visible without breaking the forum layout!):


As you move around the numbers for X / Y should change, and match the values in the built-in map (press 'm')


This should help determine whether the problem is in communication of the position data from dosbox, or whether it's more like a display problem on the Grid Cartographer 4 end.

(sorry for the inconvenience of having to post a screenshot but it'd be really helpful to debug things if you could. I tend to use but there are many out there.)
Last edited by David Walters on Sep 29, 2016 21:08, edited 2 times in total.